Szukaj


drukuj pdf
KonfiguracjaPhp

Wraz z wprowadzeniem nowej oferty hostingowej zmienia się sposób konfigurowania ustawień PHP.

Poniżej znajdziesz poradnik dotyczący nowej i starej oferty.


Plik .ovhconfig - zmiana konfiguracji PHP w serwerach nowej generacji


UWAGA: Konfiguracja to dotyczy serwerów hostingowych z nowej oferty 2014 oraz serwerów Performance.

Jak zmienić ustawienia PHP?

W ramach nowych serwerów hostingowych wprowadziliśmy PHP-FPM do naszej infrastruktury, dzięki czemu możemy przyśpiszyć działanie skryptów PHP. Dzięki temu minimalizuje się ilość połączeń do dysków I skraca czas przetwarzania kodu. W testach laboratoryjnych udało się uzyskać siedmiokortnie większą wydajność w porównaniu do starszej wersji.

Do działania PHP-FPM, ze względów bezpieczeństwa następująca funkcje są wyłączone:
register_globals
magic_quotes_gpc


Jak wybrać wersję PHP?

Należy stworzyć plik .ovhconfig w katalogu głównym konta (HOME) lub witryny ("www").

Aby korzystać z PHP 5.4 plik .ovhconfig musi zawierać następujący kod:

app.engine=php
app.engine.version=5.4
http.firewall=none
environment=production


Jakie wersje PHP są dostępne?
Możesz korzystać z PHP w wersji:

  • 5.3

  • 5.4 (domyślne)

  • 5.5


We wcześniejszych werjach serwerów wersja PHP była zdefiniowana przez app.engine.version, zarządzane przez plik htaccess. Obecnie zapisy w tym pliku typu SetEnv jak PHP_VER … są ignorowane

Aby korzystać ze starego trybu konfiguracji (poprzez plik .htaccess) ?

Plik .ovhconfig należy umieścić w katalogu głównym I wprowadzić poniższe parametry:

app.engine = phpcgi
app.engine.version = AUTO

Następnie stworzyć plik .htaccess który można zedytować w tradycyjny sposób np.: SetEnv PHP_VER 5 (patrz: Konfiguracja dla serwerów ze starszych ofert)

Stworzyłem plik .ovhconfig, ale pojawia się błąd "Not Implemented"

Oznacza to, że silnik lub wersja PHP określone w ovhconfig nie istnieją na serwerze.
Zapoznaj się z logiem błędów witryny, aby uzyskać więcej informacji o błędzie.

Za co odpowiada dyrektywa environment ?

Pozwala ona określić cache statyczny i zachowanie błędów w plikach PHP – dostępne są dwa tryby dla tej dyrektywy

Tryb rozwoju (development):

  • Pliki nie są przechowywane w pamięci podręcznej

  • Logi PHP pojawiają się na Twojej stronie (display_errors = On)


Tryb produkcyjny - domyślny (production)

  • statyczne pliki takie jak zdjęcia, wideo, audio, mają dłuższy czas przechowywania, co pozwala na przyśpieszenie działania strony

  • Logi PHP nie występują na stronie (display_errors = Off)


Za co odpowiada dyrektywa http.firewall ?

Dyrektywa ta pozwala aktywować opcję mod_security
http.firewall domyślnie jest ustawione jako none (nieaktywne)

Plik .htaccess - zmiana konfiguracji PHP w serwerach z poprzedniej generacji

Uwaga: Konfiguracja dla serwerów ze starszych ofert (oferty GP, Start oraz PLAN) oraz serwerów Personal, Pro, Business oraz Premium

Przewodnik opisuje, w jaki sposób można zmienić niektóre parametry pliku php.ini, w zależności od potrzeb. Moźesz sprawdzić konfigurację pliku php.ini na następującej stronie:

http://rodzajoferty.ovh.net/test.php np. dla Pro --> http://pro.ovh.net/test.php


Zmiana wartości poprzez SetEnv

Istnieje możliwość zmiany wartości register_globals, magic_quotes, Zend Optimizer, wyboru wersji php: php4 lub php5 poprzez SetEnv pliku .htaccess. Wystarczy utworzyć ten plik w dowolnym katalogu na swoim koncie i umieścić w nim odpowiednią zawartość.

Przykład

SetEnv REGISTER_GLOBALS 0
SetEnv ZEND_OPTIMIZER 1
SetEnv MAGIC_QUOTES 1
SetEnv PHP_VER 5


''W przykładzie pokazano, jak wyłączyć REGISTER_GLOBALS, włączyć ZEND_OPTIMIZER i MAGIC_QUOTES i korzystać z wersji PHP 5.2:
PHP_VER 5 pozwlana na uruchomienie php 5.2.x;
PHP_VER 5_3 pozwala na uruchomienienie php 5.3.x.;
PHP_VER 5_4 pozwala na uruchomienie php 5.4.x;

Przedstawione powyżej opcje można łączyć w dowolny sposób. Dajemy Ci pełną swobodę działania!''

Ustawianie session.use_trans_sid

Opcja umożliwia konfigurowanie session id, aby znajdowało się w url lub w cookie. W tym celu wystarczy wyedytować plik .htaccess z następującą zawartością:

SetEnv SESSION_USE_TRANS_SID 0


Session id będzie w cookie.

Konfiguracja ioncube
IONCUBE jest dostępny w PHP w wersji 5.2.
Uwaga: Aby korzystać z IONCUBE, parametr ZEND_OPTIMIZER musi być wyłączony.

SetEnv PHP_VER 5
SetEnv IONCUBE 1
SetEnv ZEND_OPTIMIZER 0



Więcej o PHP 5
Przewodnik dotyczący włączenia wszystkich dostępnych w OVH wersji PHP 5