Szukaj


drukuj pdf
Jak używać php 5?
Aby skorzystać z Php 5 w OVH, wystarczy przesłać przez ftp skrypty z roszerzeniem beta. Na przykład :

mój_skrypt.beta


Aby dowiedzieć się więcej o przesyłaniu danych przez ftp: Ftp

Php funkcjonuje w suexec - jest wykonywany wraz z prawami Twojego konta ftp. Poprzez php masz dokładnie takie same uprawnienia, jak przez ftp. Nie ma zatem potrzeby ustalania praw innych niż chmod 755.

Aby dowiedzieć się więcej na temat uprawnień: UprawnieniaChmod

Jeżeli Twój skrypt nie posiada odpowiednich zezwoleń albo jeżeli wystąpił błąd 505 (Wewnętrzny Błąd Serwera), jest to spowodowane złą konfiguracją Twoich skryptów. Oto wskazówki, które pomogą Ci rozwiązać problem:WewnetrznyBladSerwera

Stosowanie rozszerzenia .php z PHP5

Aby zmienić wersję php, wykonywną przez plik .php, wystarczy utworzyć plik .htaccess w katalogu Twojej strony. W notatniku, bądz innym edytorze tekstowym, wpisz:

SetEnv PHP_VER 5


- dla PHP 5.2:

SetEnv PHP_VER 5


- dla PHP 5.3:

SetEnv PHP_VER 5_3


- dla PHP 5.4 (wersja RC, nie zalecamy używać jej w środowisku produkcyjnym):

SetEnv PHP_VER 5_4


Zapisz ten plik i wgraj go przez FTP na Twoje konto, do danego katalogu. Zmień nazwę pliku na .htaccess Pliki .php będą wykonywane przez php5.

UWAGA: Hosting w OVH korzysta domyślnie z wersji php4.