Szukaj


drukuj pdf Polish
Problemy z PHP

1. Czy jest możliwość skorzystania z innej wersji PHP niż 5.x?

Tak - w serwisie 60free jest możliwość korzystania z PHP v4. Jest to możliwe poprzez nadanie skryptom rozszerzenia '.php4' (i odpowiednio dla PHP v5 - '.php5'). Rozszerzenie '.php' standardowo jest powiązane z PHP v5.
Istnieje również możliwość wyboru wersji PHP poprzez ustawienie odpowiedniej zmiennej środowiskowej. Aby ustawić własną domyślną wersję PHP należy w pliku .htaccess dodać

dla PHP v4.:
SetEnv PHP_VER 4

a dla PHP v5.:
SetEnv PHP_VER 5

Zmiana wersji będzie dotyczyła Wszystkich skryptów w katalogu oraz podkatalogach zawierającym taki plik '.htaccess'. Istnieje więc możliwość, żeby różne katalogi były interpretowane przez różne wersje PHP.

2. Skrypt który się bez problemów wykonuje na innym serwisie nie działa na 60free. Co mam zrobić?

Proszę zwrócić uwagę, że 60free jako serwis darmowy posiada pewne ograniczenia funkcjonalne. Proszę sprawdzić czy skrypty są przystosowane do pracy z konfiguracją opisaną w szczegółach oferty 60free. Najczęściej powstałe problemy są do obejścia.

3. Jak mogę zainstalować CMS'a/forum/bloga?

Większość CMS'ów (np. Mambo, Jportal, PHP-nuke) instaluje się bez problemów, jednakże z powodu ich dość zaawansowanej (lecz często nie dokońca dopracowanej) budowy, mogą występować pewne problemy z niektórymi opcjami. Na pewno nie będzie działało wysyłanie email'i bezpośrednio z 60free - proszę używać SMTP i zewnętrznego serwera. Prawdopodobnie niedługo wprowadzimy możliwość automatycznej instalacji określonego CMS'a.

4. Uruchamiam skrypt i zamiast prawidłowego działania dostaje komunikat: 'This account gets to much CPU power. Script 'mojskrypt.php' will not be started...'?

Taki komunikat oznacza, że Twoje skrypty zużywają za dużo zasobów CPU. Najprawdopodobniej będziesz musiał zoptymalizować swoje skrypty.